>

Визуальный HTML редактор

Этот визуальный HTML редактор написан на основе Microsoft DHTML Editing Control, который устанавливается на наши компьютеры вместе с IE5 и более поздних выпусков. Получившийся редактор имеет достаточно большие возможности и очень маленький размер исполняемого файла - около 20 кб, что в наше время выглядит просто нереальным, но тем не менее, редактор вполне работоспособен. Конечно, работа редактора основывыется кроме указанного выше Microsoft DHTML Editing Control ещё на не одной сотне килобайт различных библиотек, но на современном компьютере они все должны быть установлены вместе с современной ОС типа WINDOWS XP, а потому их отсутствие это скорее исключение, чем правило.

Что умеет визуальный редактор

  • работа со шрифтами - размер, цвет,фон
  • вывод информации о названии шрифта и размера под курсором
  • работа с изображениями - вставка, изменение размера
  • редактирование таблиц - удаление и добавление строк и столбцов
  • проверка орфографии через буфер обмена(требуется наличие установленного Microsoft Word)
  • работа со списком - создание, редактирование
  • работа с гиперссылками - создание и удаление
  • работа одновременно с несколькими документами в разных копиях редактора
  • из рисунка автоматически генерирует код HTML
  • любой текстовый документ автоматически переводит в HTML
  • загрузка страницы для редактирования непосредственно из Интернет
  • сохранение и печать документа

В режиме кода HTML

  1. создание шаблонов таблиц
  2. установка цвета фона на HTML странице
  3. установка кодовой страницы
  4. использование Script Java ,VB или другого кода, поддерживаемого в IE 5
  5. поддержка CSS стилей

Принимаются пожелания критика по адресу mobilsoft@vens.ru